程序员一代码搬运工
【Java学习心得和Java学习技术个人总结】

idea 版本报错:jdk版本不对应问题

报错信息: 

报错原因: 
项目中Java版本不一致,可以查看项目中的jdk配置 
1、查看项目的jdk(Ctrl+Alt+shift+S) 
File ->Project Structure->Project Settings ->Project 

2、查看工程的jdk(Ctrl+Alt+shift+S) 
File ->Project Structure->Project Settings -> Modules -> (需要修改的工程名称) -> Sources -> 

3、查看idea中Java配置 

File–>Other Settings–>Default Settings–>Compiler–>Java Compiler

如果出现的Choose Module框中是空白,无法修改Target bytecode version.则:

选中项目,右击选择Maven–>Reimport, 然后再次编译,问题解决。

————————————————
版权声明:本文为CSDN博主「djch0319」的原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接及本声明。
原文链接:https://blog.csdn.net/qq291539326/article/details/79311373/

赞(1)
未经允许不得转载:程序员一代码搬运工 » idea 版本报错:jdk版本不对应问题
分享到: 更多 (0)