程序员一代码搬运工
【Java学习心得和Java学习技术个人总结】

解决“Dynamic Web Module 3.0 requires Java 1.6 or newer.”错误

在项目的pom.xml的标签中加入:

<build>
	<plugins>  
            <plugin>  
                <groupId>org.apache.maven.plugins</groupId>  
                <artifactId>maven-compiler-plugin</artifactId>  
                <version>2.3.2</version>  
                <configuration>  
                    <source>1.6</source>  
                    <target>1.6</target>  
                </configuration>  
            </plugin>  
        </plugins>  
        </build>

保存,项目构建完成后在项目文件夹上点右键,选择Maven->Update Project Configuration,问题解决。

未经允许不得转载:程序员一代码搬运工 » 解决“Dynamic Web Module 3.0 requires Java 1.6 or newer.”错误

分享到:更多 ()